14 May 2010

Arial Black italic problem

Arial Black or Arial Black?


Arial Black is a useful font. Big and bold and, importantly, installed with Microsoft Internet Explorer 3.0 in 1996 and has been one of their Core web fonts since March that year That means most people using Windows will see text using that font in your document or web page as you intended rather than having it substituted with something else which may or may not look right.


A few years ago I was perplexed when I looked at instances where I used it and found the text had become italic. Putting it down to something wrong with my computer, or the way it was being rendered, I've been nervous about using it ever since as it seems to be fine on some computers and not on others, thinking that I would investigate one day. I finally had a spare moment today and did a quick search for the problem and wish I'd done that ages ago as it's nothing like as complicated to fix as I'd thought it might be!


What happened was that in 2008 Microsoft released Service Pack 3 for Windows XP and the update included a new version 2.40 of the font file ariblk.ttf. This was a mistake by someone at Microsoft who named an italicised version of Arial Black with that filename. Luckily, Service Pack updates retain uninstalled files so the problem can be solved by deleting version 2.40 and copying version 2.35 from the retained folder. This does mean diving into areas of your system that many of you may have never realised were there but it's pretty simple:


Go to C:\WINDOWS\Fonts folder and delete the Arial Black file. (ariblk.ttf ver. 2.40)

Now go to C:\WINDOWS\$NtServicePackUninstall$ and find ariblk.ttf (ver 2.35) copy it and paste it into the C:\WINDOWS\Fonts folder.

You should now have a normal Arial Black, and the italicised button will also work when you want it to!


Particular thanks to the good people at icrontic for the advice which I reproduce here for anyone still wondering what happened. Now I can get back to including it in designs again.

4 comments:

Clark said...

Thank you!!!

what a stupid and lazy thing for them not to fix.

Markus Mettler said...

Very clear - thank you.

MrCool said...

Awesome, works like a charm.

Roveri Philippe said...

this bug is also in windows seven!
there are really the very stupid people at microsoft!